我具有以下结构
typedef struct h{
int key;
float data;
char name[20];
}heaparr;
我想为的每个元素动态分配内存
heaparr *heap;
为了动态地为每个元素分配内存,我已经使用
heap[i]=(heaparr*)malloc(sizeof(heaparr));
但是每次我编译代码时,都会收到一个赋值类型不匹配错误。我该如何解决?预先感谢。
答案 0 :(得分:2)
您只能通过指针动态分配。如果要动态分配数组的每个元素,则每个元素必须是一个指针。
[EDIT] 感谢@David C. Rankin 指向我,在这个特定示例中,我在堆栈中声明了一个包含10个指针的数组,以编写代码更简单。您可以创建具有任意数量的元素的预定义大小的数组,但是它具有以下限制:一旦达到限制,就无法realloc
堆数据。您总是可以动态创建一个数组。
#include <stdlib.h>
typedef struct h {
int key;
float data;
char name[20];
} heaparr;
int main()
{
heaparr *heap[10];
int i;
for (i = 0; i < 10; ++i) {
heap[0] = malloc(sizeof(heaparr));
}
return 0;
}
答案 1 :(得分:2)
作为TheCrow答案的后续内容,如果您确实希望通过允许处理未知数量的struct的方式为每个heap[i]
进行分配,则可以使用 pointer -指向指针到heaparr
(例如heaparr **heap;
),然后最初分配一些指针,并为从输入中读取的每个结构分配指针。
该计划是直接的。您保留两个计数器变量。一个代表分配的指针数量,第二个代表使用的指针数量。当使用的指针数量等于分配的数量时,您只需realloc
个更多的指针,然后再尝试分配/填充下一个指针。
下面是一个简单的示例,该示例从stdin
中读取数据,并期望每一行都包含"key data name"
。最初分配了2
个指针,并且当当前分配的所有指针都已满时,例如,
#include <stdio.h>
#include <stdlib.h>
/* if you need constants, #define them or use a global enum */
enum { NPTR = 2, MAXNM = 20, MAXC = 128 };
typedef struct {
int key;
float data;
char name[MAXNM];
} heaparr;
int main (void) {
char buf[MAXC] = ""; /* read buffer */
size_t n = 0, /* current struct filled */
nptr = NPTR; /* initial/current number of pointers */
heaparr **heap = NULL; /* pointer-to-pointer to heaparr */
/* allocate/validate nptr to heap */
if (!(heap = malloc (nptr * sizeof *heap))) {
perror ("malloc-heap");
return 1;
}
while (fgets (buf, MAXC, stdin)) { /* read each line */
heaparr tmp = { .key = 0 }; /* tmp struct */
if (sscanf (buf, "%d %f %19[^'\n']", /* parse line/validate */
&tmp.key, &tmp.data, tmp.name) != 3) {
fprintf (stderr, "error: failed conversion line %zu.\n", n);
continue; /* just read next line on conversion failure */
}
if (n == nptr) { /* check if realloc needed */
/* always relloc to a temporary pointer to avoid mem-leak */
void *tmpheap = realloc (heap, nptr * 2 * sizeof *heap);
if (!tmpheap) { /* validate realloc */
perror ("realloc-tmpheap");
break; /* don't exit, original data still valid in heap */
}
heap = tmpheap; /* assign new block to heap */
nptr *= 2; /* update current pointers allocated */
}
if (!(heap[n] = malloc (sizeof *heap[n]))) { /* allocate heap[n] */
perror ("malloc-heap[n]");
break;
}
*heap[n++] = tmp; /* assign tmp to heap[n], increment n */
}
for (size_t i = 0; i < n; i++) { /* output all values */
printf ("%3d %5.1f %s\n", heap[i]->key, heap[i]->data,
heap[i]->name);
free (heap[i]); /* don't forget to free each struct */
}
free (heap); /* don't forget to free pointers */
return 0;
}
(下面读取了4个结构体的数据,上面需要realloc
)
示例输入文件
$ cat dat/intfloatstr.txt
1 1.1 my
2 2.2 dog
3 3.3 has
4 4.4 fleas
使用/输出示例
$ ./bin/dynallocstruct <dat/intfloatstr.txt
1 1.1 my
2 2.2 dog
3 3.3 has
4 4.4 fleas
内存使用/错误检查
在您编写的任何动态分配内存的代码中,对于任何分配的内存块,您都有2个职责:(1)始终保留指向起始地址的指针因此,(2)当不再需要它时可以释放。
当务之急是使用一个内存错误检查程序来确保您不会尝试访问内存或在已分配的块的边界之外/之外进行写入,不要试图以未初始化的值读取或基于条件跳转,最后,以确认您释放了已分配的所有内存。
对于Linux,valgrind
是正常选择。每个平台都有类似的内存检查器。它们都很容易使用,只需通过它运行程序即可。
$ valgrind ./bin/dynallocstruct <dat/intfloatstr.txt
==8846== Memcheck, a memory error detector
==8846== Copyright (C) 2002-2015, and GNU GPL'd, by Julian Seward et al.
==8846== Using Valgrind-3.12.0 and LibVEX; rerun with -h for copyright info
==8846== Command: ./bin/dynallocstruct
==8846==
1 1.1 my
2 2.2 dog
3 3.3 has
4 4.4 fleas
==8846==
==8846== HEAP SUMMARY:
==8846== in use at exit: 0 bytes in 0 blocks
==8846== total heap usage: 6 allocs, 6 frees, 160 bytes allocated
==8846==
==8846== All heap blocks were freed -- no leaks are possible
==8846==
==8846== For counts of detected and suppressed errors, rerun with: -v
==8846== ERROR SUMMARY: 0 errors from 0 contexts (suppressed: 0 from 0)
始终确认已释放已分配的所有内存,并且没有内存错误。
答案 2 :(得分:0)
您可以在指针的帮助下,通过获取下标的大小为每个数组索引分配内存,并以所需的数组索引大小开始循环。
也无需强制转换malloc的返回值。 找到如下所述的代码段:
typedef struct h
{
int key;
float data;
char name[20];
}heaparr;
int main()
{
int size = 4;
int iLoop = 0;
heaparr *heap[size];
for (iLoop = 0; iLoop < size; iLoop++)
{
heap[iLoop] = malloc(sizeof(heaparr));
}
return 0;
}
希望这会清除您的疑问。
答案 3 :(得分:-1)
我认为以下代码适合您...
int main
{
///In Main Function you need to allocate the memory for structure format
heaparr *heap;
int num,i; //How many structures you want it?
printf("Enter the size");
scanf("%d",&num);
heap=malloc(num*sizeof(struct heaparr));
for(i=0;i<num;i++)
scanf("%d %f %s",&heap[i].key,&heap[i].data,heap[i].name);//access members and store data
for(i=0;i<num;i++)
printf("%d %f %s",heap[i].key,heap[i].data,heap[i].name);//print the data
return 0;
}