我试图在hackerrank上解决这个问题。
你有四个整数:N,S,P,Q。您将使用它们来创建具有以下伪代码的序列。
a[0] = S (modulo 2^31)
for i = 1 to N-1
a[i] = a[i-1]*P+Q (modulo 2^31)
您的任务是计算序列中不同整数的数量。
Sample Input
3 1 1 1
Sample Output
3
Constraints
1<= N <= 10^8
0<= S,P,Q < 2^31
这是我在c ++中的解决方案..大多数时候我都会遇到分段错误..我知道这应该是使用位数组来解决的......但是想知道为什么这不起作用。
#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
int main() {
unsigned long long n,s,p,q;
cin >> n >> s >> p >> q;
//declaring array to hold sequence
unsigned long long a[n];
// for loop termination
bool termination_check = true;
//initializing sequence
//s<2^31 hence, s modulo 2^31 is always s
a[0] = s;
//creating sequence
for(int i=1;i<n;i++){
//calculating next term of sequence..
a[i] = (a[i-1]*p)+q;
//since a[i] modulo 2^31 is a[i] when a[i] < 2^31
if(a[i]>=pow(2,31)){
a[i] = a[i]%31;
//when the current term matches with any of previous terms of sequence, then the
//terms just repeat after that (since p and q are constants)
for(int j=0;j<i;j++){
if(a[i]==a[j]){
cout <<i << endl;
//i was trying to use break but dont know why, it did not work
termination_check = false;
break;
break;
}
}
}
}
//if there was no termination of loop then all the terms are distinct
if(termination_check){
printf("%llu \n", n);
}
/* Enter your code here. Read input from STDIN. Print output to STDOUT */
return 0;
}
答案 0 :(得分:0)
此答案适用于以前版本的代码。代码现已在问题内编辑(j = i和i = n由两个中断代替)
查看遇到案例时发生的事情
a[i] == a[j]
您将j
设置为i
,然后将i
设置为n
。但i
小于n
,因此语句j<i
仍然有效。然后你的for循环继续运行,所以你的程序试图评估
a[i] == a[j]
使用您指定的新值,您实际上是在询问是否
a[n] == a[i]
但如果您的数组a
是一个大小为n
的数组,则会导致未定义的行为。
答案 1 :(得分:0)
是的,您可以在C ++中拥有unsigned long long
个数组。但你所拥有的不是数组:unsigned long long a[n];
要求n
为常数。 (这在C中会有所不同,但你在编写C ++)。
它仍然运行的是一个编译器扩展,它允许你混合使用C和C ++,但是没有定义行为。特别是错误处理似乎缺乏。