编程新手,你们能告诉我在Java中进行多行输入的最佳方法吗?像这样的东西。
程序1st向用户询问病例数。 然后要求用户输入2个以空格分隔的整数。
第一列仅指示列数。 id还希望能够获取第二列整数的总和(25000 + 1000 =?)
sample input
2
1 25000
2 1000
sample output
26000
答案 0 :(得分:1)
尝试
import java.util.Scanner;
public class Launcher {
public static void main(String[] args) {
try (Scanner scanner = new Scanner(System.in)) {
int inputs = scanner.nextInt();
int sum = 0;
while (inputs-- > 0) {
// input 1 2500 in one line is read as two different inputs
int row = scanner.nextInt();
int value = scanner.nextInt();
sum += value;
}
System.out.println(sum);
}
}
}
您可以尝试
sample input
2
1 25000
2 1000
sample output
26000
答案 1 :(得分:0)
您可以使用类似的东西
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int rows = new Integer(scanner.nextLine());
int sum = 0;
for (int i = 0; i < rows; i++) {
sum = sum + new Integer(scanner.nextLine().split(" ")[1]);
}
System.out.println(sum);
}
}