字符串java上的空指针异常

时间:2016-03-22 01:56:14

标签: java string nullpointerexception

代码是缩短名称。

当我在Hackerrank中执行时,temp.length(),temp.toUpperCase(),temp.substring()上有 NullPointerException Visit the question here

第一行包含一个整数N,表示测试用例的数量。

示例输入

3

Mohandas Karamchand Gandhi

Mervin R Sundharam

MUTHU

示例输出

M K Gandhi

M R Sundharam

MUTHU

import java.io.*;
import java.util.*;

public class Solution {

    public static void main(String[] args) throws IOException {
        Scanner sc= new Scanner(System.in);
        int size= sc.nextInt();
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

        String ar[] =new String[size];
        for (int i= 0; i < size; i++) {
           ar[i]=br.readLine();
       }

        for(int i= 0;i<size;i++){
            String temp=" ";
            temp=ar[i];
            int pos=0;
            for (int j= 0; j < temp.length(); j++)
                if(temp.charAt(j)==' '){
                    System.out.print(temp.toUpperCase().charAt(pos)+ " ");
                    pos=j+1;
                }
            }
            System.out.println(temp.toUpperCase().charAt(pos)+temp.substring(pos+1));
        }
    }
}

1 个答案:

答案 0 :(得分:-1)

在第一个for循环中从ar[i]=br.readLine();更改为ar[i]=sc.nextLine();