在Codemarshal(algo.codemarshal.org)在线判断存在问题,我每次都会得到错误的答案。问题如下:
CPU:1s
内存:1024MB所以这是交易,给定一个整数n,按递增顺序打印从0到n的所有整数。
输入
输入以正整数T开始,测试用例数。随后是T行,每行包含一个整数n。输出
对于每个测试用例,产生一个包含单个空格的行,从0到n按升序排列。示例输入
2 1 5
示例输出
0 1 0 1 2 3 4 5
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
int main()
{
int t;
long long int n,i;
scanf("%d",&t);
while( t-- ){
scanf("%lld",&n);
for( i = 0; i <= n; i++ ){
printf("%lld",i);
if( i != n )
printf(" ");
}
printf("\n");
}
}
答案 0 :(得分:0)
这对打印值更有效:
printf("0");
for ( i=1; i < n; i++ ) {
printf(" %ld", i ):
}
printf(" %ld\n", n);
但是期望的&#34;正确&#34;答案可能需要检查输入错误(输入任何输入的非数字或EOF),并检查t = 0或n = 0,并检查负数。