Linux中的C库中是否存在函数* dec / * enc(例如be64enc)?它们确实存在于FreeBSD中,但在Linux中我只能找到hto * / * toh函数,这些函数恐怕具有完全相同的功能。
提前致谢。
答案 0 :(得分:-1)
他们没有:
$ uname
Linux
$ man be64enc
No manual entry for be64enc
快速谷歌搜索确认了这一点,没有Linux条目。
我找不到那些功能应该做什么。这是该主题的唯一手册页(BSD),并没有特别的帮助:
BYTEORDER(9) BSD Kernel Developer's Manual BYTEORDER(9)
NAME
bswap16, bswap32, bswap64, be16toh, be32toh, be64toh, htobe16, htobe32, htobe64, htole16,
htole32, htole64, le16toh, le32toh, le64toh, be16enc, be16dec, be32enc, be32dec, be64enc,
be64dec, le16enc, le16dec, le32enc, le32dec, le64enc, le64dec -- byte order operations
SYNOPSIS
#include <sys/endian.h>
uint16_t
bswap16(uint16_t int16);
uint32_t
bswap32(uint32_t int32);
uint64_t
bswap64(uint64_t int64);
uint16_t
be16toh(uint16_t big16);
uint32_t
be32toh(uint32_t big32);
uint64_t
be64toh(uint64_t big64);
uint16_t
htobe16(uint16_t host16);
uint32_t
htobe32(uint32_t host32);
uint64_t
htobe64(uint64_t host64);
uint16_t
htole16(uint16_t host16);
uint32_t
htole32(uint32_t host32);
uint64_t
htole64(uint64_t host64);
uint16_t
le16toh(uint16_t little16);
uint32_t
le32toh(uint32_t little32);
uint64_t
le64toh(uint64_t little64);
uint16_t
be16dec(const void *);
uint32_t
be32dec(const void *);
uint64_t
be64dec(const void *);
uint16_t
le16dec(const void *);
uint32_t
le32dec(const void *);
uint64_t
le64dec(const void *);
void
be16enc(void *, uint16_t);
void
be32enc(void *, uint32_t);
void
be64enc(void *, uint64_t);
void
le16enc(void *, uint16_t);
void
le32enc(void *, uint32_t);
void
le64enc(void *, uint64_t);
DESCRIPTION
The bswap16(), bswap32(), and bswap64() functions return a byte order swapped integer. On
big endian systems, the number is converted to little endian byte order. On little endian
systems, the number is converted to big endian byte order.
The be16toh(), be32toh(), and be64toh() functions return a big endian byte ordered integer
converted to the system's native byte order. The return value will be the same as the argu-
ment on big endian systems.
The le16toh(), le32toh(), and le64toh() functions return a little endian byte ordered inte-
ger converted to the system's native byte order. The return value will be the same as the
argument on little endian systems.
The htobe16(), htobe32(), and htobe64() functions return a integer in the system's native
byte order converted to big endian byte order. The return value will be the same as the
argument on big endian systems.
The htole16(), htole32(), and htole64() functions return a integer in the system's native
byte order converted to little endian byte order. The return value will be the same as the
argument on little endian systems.
The be16enc(), be16dec(), be32enc(), be32dec(), be64enc(), be64dec(), le16enc(), le16dec(),
le32enc(), le32dec(), le64enc(), and le64dec() functions encode and decode integers to/from
byte strings on any alignment in big/little endian format.
SEE ALSO
byteorder(3)
HISTORY
The hto*() and toh*() functions first appeared in FreeBSD 5.0, and were originally developed
by the NetBSD project.
The encode/decode functions first appeared in FreeBSD 5.1.
BSD April 29, 2002 BSD
如果您指定了您所面临的问题以及您尝试过的问题,也许我们可以更好地帮助您。提出一个新问题,详细说明您的问题,您尝试过的内容以及之前可能适合您的问题。