我正在研究Rails 4.1.0。我已经在我的应用程序中生成了leaves_controller和Leave模型。
但是应用程序为new_leafe,edit_leaf等创建了leaf的路由。
实际上我只想要单词Leave as Leave,如new_leave_path,edit_leave_path。
如果有任何想法在Rails中单一化名称,请分享。
答案 0 :(得分:3)
如果只是您想要更改的路线,可以使用as:
选项:
#config/routes.rb
resources :leaves, as: "leave"
-
或者,如果您想在Rails中设置该术语,您可能希望使用这样的Inflector
:
How do I override rails naming conventions?
#config/initializers/inflectors.rb
# Add new inflection rules using the following format
ActiveSupport::Inflector.inflections do |inflect|
inflect.irregular 'leave', 'leaves'
end