运行npm -version时出现npm错误

时间:2019-08-10 06:17:13

标签: node.js npm npm-install

我需要Angular 8 CLI的node10 +版本,并且在使用node10.16.2时,出现以下错误,并且在运行npm build时看到相同的错误

npm-v10.16.2 -v
/auto/sw/packages/node/v10.16.2/lib/node_modules/npm/bin/npm-cli.js:84
let notifier = require('update-notifier')({pkg})
      ^^^
  

SyntaxError:严格模式之外尚不支持块范围的声明(let,const,函数,类)
  在exports.runInThisContext(vm.js:53:16)处
  在Module._compile(module.js:387:25)
  在Object.Module._extensions..js(module.js:422:10)
  在Module.load(module.js:357:32)
  在Function.Module._load(module.js:314:12)
  在Function.Module.runMain(module.js:447:10)
  在启动时(node.js:148:18)
  在node.js:405:3

如何解决此问题?

1 个答案:

答案 0 :(得分:0)

您需要更新您的节点程序包以解决此问题。

如果您使用的是ubuntu,请尝试运行

sudo npm install -g n
sudo n stable

这将安装最新的节点程序包。

相关问题