他们俩都认为编程风格不好吗?
编辑:下面的代码只是将i的de值添加到pseudoRandom变量中,以生成一个“随机”数字...这只是为了澄清我的问题。
int pseudoRandom{};
int i{44};
while(i)
{
pseudoRandom += i;
i--; // decrement here
}
或者:
int pseudoRandom{};
int i{44};
while(i--) // or here
{
pseudoRandom += i;
}
谢谢!
答案 0 :(得分:1)
您初始化一个控制循环的变量,在每次迭代中对其进行测试,并在每次迭代中对其进行调整而不会失败。这些表示for
循环,而不是while
。
因此,我想说这不是惯用的C ++。适当的习惯用法是:
for(int i = 44; i != 0; --i)
{
pseudoRandom += i;
}
如果循环后需要i
,则可以将int i = 44
从for
语句中移出。但是否则,其他任何事情都不会改变。